Issue is resolved and users can now place orders as a guest on the website
Posted Jun 10, 2026 - 12:01 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 10, 2026 - 11:27 BST
Investigating
We have identified an issue preventing non logged in users (guests) from placing orders on the KFC UK & Ireland websites. We are working on a fix and it will be resolved shortly.
Issue started on the 4th June 2026.
All other functionality on web and app is unaffected and any logged in users on website can still place orders as usual.
Posted Jun 10, 2026 - 11:24 BST
This incident affected: Ordering (Mobile Ordering on web) and Brand Website - Prod.