www.kfc.co.uk certificate expiry

Incident Report for KFC

Resolved

The incident has been resolved with a workaround while the root cause is currently being investigated by GTRM
Posted Aug 03, 2026 - 14:36 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 03, 2026 - 12:18 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 03, 2026 - 12:14 BST

Update

As a workaround, the previous Sectigo certificate has been reissued while the issue with the SBD certificate renewal is being investigated and resolved
Posted Aug 03, 2026 - 12:14 BST

Investigating

We are currently investigating this issue.
Posted Aug 03, 2026 - 12:12 BST